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General Information
“SlovoEd” is a multi-language dictionary for devices with Palm OS (version 3.1 and higher)1.

Advantages of the program are:
Great number of word entries
Low memory consumption
The possibility to install several language pairs
Convenient interface with color support

Color formatting of word entries

The possibility to change existing entries using a powerful built-in editor
The ability to add new entries
Search history (last words that you searched), you can see any word from the history again at any time
Transcription support
Full screen mode to show translation
The possibility to install SlovoEd to expansion cards (Memory Stick, Compact Flash, Secure Digital, MMC)
Support of dictionaries with different code pages (for example, Russian-German dictionary)
Includes a resident module that allows you to translate words without exiting an active application.
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On devices with Palm OS 3.5 and higher you can use all the capabilities of SlovoEd. On devices with Palm OS 3.1 and
3.3 some options are unavailable (for example, Use Clipboard to get text in resident module). Also not all such devices
support gray scales (gray scales are used for formatting word entries). In addition, the resident module is not implemented
on the TREO 180, TREO 270 devices and devices with Palm OS 5.0.
2

High data compression ratio for dictionaries with a high access rate is available due to special technology developed by
Paragon Software (SHDD) (http://www.penreader.com).
Information about all dictionaries that we develop is available at www.penreader.com/PalmOS/SlovoEd.html.
SlovoEd supports correct sorting order for each national language according to its alphabet. For example some languages
(Czech, Slovak, Hungarian and so on) have special characters and combinations of letters like
which are considered as one letter. Despite of this fact dictionary entries are listed in the correct order.

,

For each language pair there may be several editions of dictionaries for “SlovoEd” software engine2: compact, extended,
basic and so on. You can choose and install any of available editions depending on your needs.
Demo-version limitations:
The more you use an unregistered dictionary, the more you see a message about its registration procedure. To register
your copy of the dictionary, enter the serial number in the following dialog box:

The information on how to buy SlovoEd and how to obtain the serial number is available on our web site
www.penreader.com/PalmOS/SlovoEd.html using link: BUY.

Installation
Note:
1.

2.
3.

If you want to use national language dictionaries, and this national language is not supported by standard Palm
OS (for example, Russian, Greek or Turkish symbols), you have to install national language support system (that
allows you to use national symbols on your Palm). Only in this case you will be able to type words in national
language, and “SlovoEd” will be able to display translations with specific national symbols correctly. If you
don’t install national localization system, you will see unreadable symbols (gibberish)3.
We recommend you to use our localization system PiLoc. You can find more detailed information about PiLoc at
our web site: http://www.penreader.com/PalmOS/PiLoc.html. Demo versions of PiLoc are available at
www.penreader.com/download/Localization.html.
Some of the dictionaries we develop, for example, Russian-German and Russian-French dictionaries, don’t work
without PiLoc (version 2.20 and higher) at all, as they use API of PiLoc. In the following instructions we assume
that you use PiLoc 2.20 or higher.
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You can read configurations of the dictionary for each language pair on our web site.
www.penreader.com/PalmOS/SlovoEd.html using an appropriate link in section: more languages.
3
You don’t need to install national localization system if you use English, German, Hungarian, French, Spanish, Italian
and Dutch languages.
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1.
2.

3.

4.
5.

If you have an old version of SlovoEd installed you should remove it first. You can read about uninstallation
procedure in appropriate documentation to installed version. Otherwise use uninstallation procedure described in this
document.
Run the Palm Desktop program on your desktop computer (the Palm Desktop icon is on the desktop). Then click the
Install Tool icon in the Palm Desktop window.

In the appeared window add the following files: SlovoEdXXXX.prc (”SlovoEd” program with interface in national
language, XXXX – is abbreviated name of national language4) and dictionary files (two files for bi-directional
dictionary and one file for uni-directional dictionary). For example, for bi-directional English–French dictionary you
should install French_English.prc and English_French.prc, for uni-directional German-Spanish dictionary only
German_Spanish.prc. To add a file into the Install Tool window you should drag-&-drop the file there or press the
Add button and set location of the file you want to add.
Press the Done button.
Synchronize your device with the desktop computer using the HotSync program. For synchronization open the
application HotSync and tap the icon in the center of the screen.

After synchronization PiLoc will be installed.
Installation to expansion card
If you want to install the whole “SlovoEd” (the program and dictionary files) to expansion card (Memory Stick,
Compact Flash, Secure Digital, MMC), you should do the following:
1. Synchronize your device with the expansion card inside with your desktop computer.
2. On the desktop computer click twice on the dictionary file (for example on the English_Russian.prc file). Then you
will see the following window:
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You can also install ”SlovoEd” with the English interface. To do this, you should install the SlovoEd.prc file instead of
the SlovoEdRus.prc file.
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3.
4.

Select the file and press the Change Destination button.
Select the file once again and move it into the expansion card window.

5.
6.

Then press the ОК button.
Repeat this procedure for every dictionary file and then the synchronization button on your device.

You also can install at first “SlovoEd” to the main memory and then move it to the expansion card or move only
dictionary files to the expansion card. How to do this read in the section Installation to expansion card of the paragraph
Using “SlovoEd”.

Using “SlovoEd”
If localization system is installed on your Palm OS device, you should set national language as system one. After starting
the SlovoEd program your organizer’s screen will appear as follows:

There is an edit field for entering words to be translated at the top of the screen. You can enter words in this field in
different ways:
•
•
•
•

Using Graffiti.
Using on-screen keyboard.
Using the Copy-Paste operation. Paste your text by using the Paste item from the menu, Graffiti or by clicking on the
appropriate button at the top of the screen.
Turning on the Paste on start option in the Options menu. With this option on, the Clipboard content will be pasted
into the edit field at every start of the program.

If a word entered in the field exists in the dictionary, its translation will be displayed below the edit field.
You can look through the dictionary by clicking the arrows on the screen or by pressing the Up/Down buttons on your
Palm organizer’s case.
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The elements of the program interface are shown in the picture below:

1.
2.
3.
4.

5.
6.
7.
8.
9.

10.
11.
12.
13.
14.

Edit field.
List of words available in the dictionary.
Scrolling arrows. Using these arrows you can scroll the list of stored entries. Alternate scrolling is provided with the
Up/Down buttons on your device.
Translation of the word entry. You can unwrap a word translation on the full screen (using button 8). To return to the
main window of the dictionary, tap the arrow of the right upper corner.
The word entry text is formatted with colors5 that usually means the following: part of speech is blue, wordcombinations and phrases are green, translation of words is black, additional information (transcription or
description) is gray.

Scrollbar. You can scroll long translation when the content doesn’t fit the screen.
Graffiti indicator. Allows you to see the current language operation mode of Graffiti, and to switch between national
and default languages. If you use the localization system PiLoc 2.0 and higher, the indicator allows you to switch
between dictionaries within the pair.
“History” button. History displays 6 last searched words.
“Full screen” button. By pressing this button, you will see translation of any word in full screen mode.
“Dictionary” button. Switches between dictionaries within a selected pair.
You can also choose the dictionary in one of the following ways:
with the help of the program menu;
if you select to activate “SlovoEd” with a hardware button and run the program by pressing this button;
pressing the button a second time will reverse the direction of translation;
the active dictionary reverses every time you start typing a word in the opposite language;
the dictionary switches to the opposite one automatically, if you change current Graffiti layout;
almost every word in the translation field is a link to another lexical entry (except transcription). If you tap a
word twice, you will see the lexical entry from the opposite dictionary.
“Back” button. Shows previous lexical entry.
“Copy” button. Copies selected word into Clipboard.
“Paste” button. Inserts the Clipboard contents into the edit field.
“Clear” button. Clears the edit field.
“Select” button. Selects the contents of the edit field.

The “SlovoEd” menu includes three sections:

5

Text is formatted with gray scales on devices with black and white screens (if your device supports gray scales).
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Edit menu performs Copy, Paste, Select and Clear operations with text in the edit field. In addition you may access
keyboard or Graffiti help.
Dictionary > Change dictionary menu allows you to change the active dictionary, delete available dictionaries or move
any available dictionary to the expansion card.

Note! If you delete a dictionary from the list, in case it is bi-directional, the pair dictionary will also be deleted. For
example, if you want to delete English-French part of the bi-directional dictionary, it will be deleted along with FrenchEnglish dictionary.
The Dictionary->Edit translation menu allows you to edit translation of any word entry in any dictionary.

Translation of the word entry is highlighted with different colors.
The Add/Edit entry window has the following elements:
1. word entry translations;
2. list of styles used to distinguish elements of the translation;
3. the “Apply” button to apply changes made to an entry;
4. next or previous element of translation;
5. the “Delete” button deletes any element in translation;
6. edit field elements
To edit translation of any word entry, go to the element of the translation to be edited by using buttons 4, and make
desired changes. Then tap the “Apply” button. Your changes will take effect then. Tap the “Save” button, if you accept
the new appearance of the translation.
To add a new word and its translation, use the Dictionary->Add new entry menu.
To add a new entry, do the following:
1. Enter a new word. You will see this word in the list of the dictionary’s entries.
7

2.

Then tap the “Edit translation” button to enter translation of a new word. To do this, set the cursor in the
edit field in the “Add/Edit entry” window and enter the translation for the new word.

3.

Select elements of the translation and choose styles for them.

4.

When you finish editing the translation, tap the “Save” button. You will see the new entry in the dictionary.

To delete dictionary entries, use the Dictionary->Delete selected entry menu.
You can disable all your changes of the dictionary at any time through the Options > View Options menu:
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Menu item About… displays information about the active dictionaries and the number of available entries.

You can tune the “SlovoEd” functionality in the Options menu. The Option menu has three sections: Common Options,
View Options and Resident Options.

Common Options
•
•
•
•
•

Paste on start. By choosing this option, the content of the Clipboard will be inserted into the edit field at every start
of the program.
Paste selected text when changing dictionaries. When you switch dictionaries, the text selected in the translation
field is inserted into the edit field, and the search starts.
Do copy with Exit. When you exit SlovoEd, translation of the last searched word is copied to the Clipboard. If this
option is on, you can paste translation in any document.
Cache cards dictionaries. A part of the dictionary moved to the memory card is put in the cache when you first run
SlovoEd. This procedure makes SlovoEd work faster. Read more about this option in the Installation to expansion
card section.
Clear history. The whole history (last 15 words which you searched in the dictionary) will be erased.

View Options
•
•
•

Large letters in translation. All the words in the translation field will be displayed in large fonts.
Disable all user dictionary changes. Disables all changes of word entries.
Use black and white mode. Disables color formatting of word entries.

Resident Options (this menu item is not available on devices with Palm OS 5.0)
•
•
•

Kind of resident activation. You can select from a popup menu, whether the resident module of “SlovoEd” is on
and how it is activated.
Full Screen mode in translation. In the resident module you will see all translations in the full screen mode.
Use Clipboard to get text. In some applications, the clipboard is necessary for resident working. Such applications
are Mail, Web applications (such as AvantGo, Blazer, WebClipping), WordSmith, DocumentsToGo. This option sets
whether resident will be able to get a selected text in the above described applications. If you turn on this option, you
can lose some clipboard data (but not necessarily).

Installation to expansion card
9

If your device has an expansion card (Memory Stick, Compact Flash, Secure Digital, MMC), you can: install
dictionaries to the memory card, install the program to the card or install both of the program and dictionaries to the card.
Placing dictionaries on expansion card
To install only dictionaries to the expansion card, open the Change dictionary menu and choose the dictionary you
want to install to the card. Then tap the Move button.

If you move your dictionary to the memory card, SlovoEd will work more slowly than if it was installed in RAM.
When you first run SlovoEd, part of dictionary files is copied to the cache. After you exit the dictionary, the part of
dictionary files can be saved in the cache or deleted from it. It is set with the Cache cards dictionaries option in
Common Options (if this option is checked, the part of the dictionary will be saved in the cache after you exit SlovoEd;
if this option is unchecked, the part of dictionary will be removed from the cache and will be copied to the cache again
when you start SlovoEd next time).
Placing the whole program on the expansion card
To move the whole program from the main memory to the memory card you should switch off the resident module,
open the Copy menu in the Palm Applications window. Then choose SlovoEd and copy it to the memory card.

Then go to the memory card and run SlovoEd from the card.
Attention! If you start SlovoEd from the memory card, you won’t be able to use resident module of the program.

Using the resident module6
Choose a way for calling resident to activate the resident part of SlovoEd. Resident allows you to translate words without
exiting an application that is currently active. Just select the word you would like to translate and start the resident module
by the method you set in the Resident Options dialog. The window will appear at the bottom of the screen. If the
dictionary doesn’t contain this word, you’ll see the list of surrounding words.
If the word is included in the dictionary, you will see its translation.

6

In this version of the program the resident module does not work on devices with Palm OS 5.0
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If you want resident to show translations in the Full Screen mode, go to the main window of SlovoEd and turn on the
Full Screen mode in translation option in Resident Options. If you want to see only one separate long word entry in the
full screen mode you should open the menu in the resident module and choose Full Screen mode.

While working with the resident module, use the options that were previously selected in Options dialog of the main
program. If these options don’t suit you or you don’t like the functionality of the resident module, you can run the main
program with the help of menu or the menu shortcut

R.

You can copy the translation into the Clipboard either manually or automatically (if you checked the option Do Copy
with Exit in the Common Options menu).
You can close the resident module window by tapping on the close button in the right corner of the resident window or by
tapping anywhere outside the resident window. You can also close the resident window by selecting Exit in the File menu
or by the shortcut

I.

You can switch between dictionaries in the active pair by selecting the Change dictionary item from the menu or by the
shortcut

T.

When the resident displays the translation list, you can return to search mode by selecting the Go to Search item in the
File menu, by tapping button, or using Backspace shortcut in Graffiti field.
If the translation list is being displayed, you can go to the translation of the previous or next entry by pressing the
Up/Down hardware buttons on your device.
Attention! The program has a repeating reboot protection. In case the device reboot occurs more than once in a minute,
the resident part of “SlovoEd” doesn’t run.
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Uninstallation
1.
2.
3.

Disable the resident module. To do this open the menu and choose Options > Resident > Kind of resident
activation > No resident activated.
Go to the Applications screen.
Open the menu and choose App > Delete. Then select “SlovoEd” and delete it.

Support and updates service
If you have any questions concerning SlovoEd and PiLoc programs contact technical support service of Paragon
Software (SHDD):
Tel: (095) 408-61-79, 408-76-77
(Operation time of technical support line is 11.30 - 19.00 Moscow time)∗
Web: http://www.penreader.com
911@penreader.com
In North America (USA, Canada, Mexico) the “SlovoEd” program is distributed and supported by Smart Link
Corporation, an official representative office of Paragon Software (SHDD):
Smart Link Corporation
18401 Von Karman Ave.,
Ste. 450, Irvine, CA 92612, USA
Free hot line: (800) 256 4814
FAX: (949) 552 1699
Email: info@smartlinkcorp.com

How to buy SlovoEd dictionaries for Palm OS
To register your copy of SlovoEd dictionaries you should buy registration number. You can find detailed information
about buying procedure on our web site:
http://www.penreader.com/PalmOS/SlovoEd/articles/Shopping_area_for_SlovoEd.html
Please contact us if you have any problem with placing your on-line order:
911@penreader.com
If you are located in North America (USA, Canada, Mexico) you can buy the “SlovoEd” program via Smart Link
Corporation, an official representative office of Paragon Software (SHDD).
Please, call us: (800) 256 4814 or send your request by E-mail: info@smartlinkcorp.com or by fax: (949) 552 1699

Dear customers!
We will be glad to get your suggestions and comments that will help us to increase our
programs quality.
Thanks you for your comments and suggestions!

∗

When calling from outside Russia, please consider time shifts: Moscow is 11 hours ahead of San-Jose, 8 hours ahead
of New York, 3 hours ahead of London, 2 hours ahead of Munich and Paris, 6 hours behind Tokyo. Moscow office
operation hours are from 11.30 till 19.00 by Moscow local time.

© Paragon Software (Smart Handheld Devices Division), Dolgoprudny, Moscow Region, Russia
18.04.2002
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